Autoswitch Model AS5P Troubleshooting

Troubleshooting an Autoswitch on the Work Bench

It is always recommended you pre-test operation of accessories of any kind before being installed on your vehicle. Especially important when the accessory is electrical, electronic and involves over an hour of detailed labor and vehicle dissasembly. If the product being installed is defective, you just saved a great deal of time and effort, and can go direct to working with the supplier to remedy the problem. If a problem arrises after the product is installed you already know to troubleshoot your wiring not the product itself.

With all that said, lets test the autoswitch on the bench or at your shop before you install it. You will need a 12-14 Volt power source and a Volt meter/Ohm meter.

  1. Unpack the Autoswitch AS5P . Apply +12V to the red wire and ground the black wire. You should see the red LED illuminate for 1 second.
  2. Touch the yellow wire to +12V source for 1.2 second or longer and the LED starts flashing fast orange. Now release the yellow wire from the 12V power during the fast flash.
  3. The violet wire is now energized and the LED is lighted green. Check for voltage at the end of the violet wire. It would be aproximately 1.5 to 2.0 volts less than your input voltage on the red wire. (reverse voltage protection reduces voltage level)
  4. Repeat step 2 to de-energize the violet wire, or simple pull the power off the red wire
  5. If you dont have a volt meter for this bench test then just apply the violet to your light relay and see if it clicks over. (You are testing the light kit on the bench too, I hope?)
  6. You have proven your AS5P is GOOD. So please remember that before you email for support if the lights dont work.

Toubleshooting an Autoswitch Installation

Check your connections. Check your connections. Check your Connections.

If you check your connections we are 99.5% certain the problem will be solved. These little circuits over the years of refinement (version 5 now) have become excellent at surviving your misuse, abuse, bad installs, bike drops, reverse voltage, bad relays etc.

Some addtional tips:

  • If you care about your work and not paying by the hour to do it, dump the red wire clips. Solder all your connections. Since most connections are a T type and hard to wrap, I use a dab of silicon glue or pieces of plastic tube and other ways to insulate well the connection. Be sure the silicon hardens before closing up the bike or powering up!
  • If your lights blink OFF and then back ON, you have a loose connection either to the relay coil or the high amp wires that the relay is controlling. Dont ignore the ground connections to the lights or relay.
  • If your lights go off and you have to use the Autoswitch to turn them back on then power to the Autoswitch red or black wire is intermittent.
  • Get your voltmeter and test for voltages at the inputs and outputs of the Autoswitch.
  • If the LED is green you MUST have voltage coming from the violet wire. Disconnect your relay coil and test again, maybe the coil is bad or shorted.
  • The LED turns red upon power up, 97% chance the circuit is working fine.

©2011 Antenna World, Inc. | Website services provided by idproductions